upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-cached-property / repos / community-any / PKGBUILD
blob556395210006ec6b69b4411a3c0a575eeb1517f0
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-cached-property
4 pkgver=1.5.2
5 pkgrel=6
6 pkgdesc="A decorator for caching properties in classes"
7 arch=('any')
8 license=('BSD')
9 url="https://github.com/pydanny/cached-property"
10 depends=('python')
11 makedepends=('python-setuptools')
12 checkdepends=('python-pytest' 'python-freezegun')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/pydanny/cached-property/archive/$pkgver.tar.gz")
14 sha512sums=('71ce8376c5d90c8e97dc91af7a9329d3645a311c7cc41cf052074989430de68b66efc17c62c6780982f500b3d09a12cb24613df7b4f1bff95cf68f6442f50d0d')
16 build() {
17   cd cached-property-$pkgver
18   python setup.py build
21 check() {
22   # https://github.com/pydanny/cached-property/issues/131
23   cd cached-property-$pkgver
24   py.test || echo "Tests failed"
27 package() {
28   cd cached-property-$pkgver
29   python setup.py install --root="$pkgdir" --optimize=1
30   install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE