upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-cattrs / repos / community-any / PKGBUILD
blob784e487d7e738618d0dd01e52b2ae43f512ecb96
1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
3 pkgname=python-cattrs
4 _pipname=${pkgname#python-}
5 pkgver=22.2.0
6 pkgrel=4
7 pkgdesc='Complex custom class converters for attrs'
8 arch=(any)
9 url="https://github.com/Tinche/$_pipname"
10 license=(MIT)
11 depends=(python
12          python-exceptiongroup
13          python-attrs)
14 makedepends=(python-{build,installer,wheel}
15              python-poetry-core)
16 # checkdepends=(python-pytest)
17 _archive="$_pipname-$pkgver"
18 source=("https://files.pythonhosted.org/packages/source/${_pipname::1}/$_pipname/$_archive.tar.gz")
19 # source=("$url/archive/v$pkgver/$_archive.tar.gz")
20 sha256sums=('f0eed5642399423cf656e7b66ce92cdc5b963ecafd041d1b24d136fdde7acf6d')
22 prepare() {
23     cd "$_archive"
24     # Upstream test suite uses addopts to run benchmarks, drop them
25     sed -i -e '/^addopts/d' pyproject.toml
28 build() {
29         cd "$_archive"
30         python -m build -wn
33 # check() {
34 #     cd "$_archive"
35 #     pytest
36 # }
38 package() {
39         cd "$_archive"
40         python -m installer -d "$pkgdir" dist/*.whl
41         install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE