1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
4 _pipname=${pkgname#python-}
7 pkgdesc='Complex custom class converters for attrs'
9 url="https://github.com/Tinche/$_pipname"
14 makedepends=(python-{build,installer,wheel}
16 # checkdepends=(python-pytest)
17 _archive="$_pipname-$pkgver"
18 source=("https://files.pythonhosted.org/packages/source/${_pipname::1}/$_pipname/$_archive.tar.gz")
19 # source=("$url/archive/v$pkgver/$_archive.tar.gz")
20 sha256sums=('f0eed5642399423cf656e7b66ce92cdc5b963ecafd041d1b24d136fdde7acf6d')
24 # Upstream test suite uses addopts to run benchmarks, drop them
25 sed -i -e '/^addopts/d' pyproject.toml
40 python -m installer -d "$pkgdir" dist/*.whl
41 install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE