1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-cerberus
6 pkgdesc="Lightweight, extensible schema and data validation tool for Python dictionaries"
7 url="https://github.com/pyeve/cerberus"
10 depends=('python' 'python-setuptools')
11 makedepends=('python-build' 'python-installer' 'python-wheel')
12 checkdepends=('python-pytest-runner' 'python-pytest-benchmark')
13 source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
14 sha512sums=('c816b426ed1b32367d1e8f1c26d6ddd4b49c6578540e688baf693e3094a05800f645cfe879be6378c1e9be9899cad7bc2ad1ed9844d6762d2ef6e0cc54a7476a')
15 b2sums=('6fabfcf32e26ee7f4881b64ce9c3098a27949d95fd0998e09b7adcc3b834033f904a07b6e9b2cadea218b952142f6c2bc6051d8c208a14d6e8172a0c3823c38b')
19 python -m build --wheel --no-isolation
20 # NOTE: remove build dir as pytest otherwise chokes on duplicate imports
31 python -m installer --destdir="$pkgdir" dist/*.whl
33 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/