upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-cmd2 / trunk / PKGBUILD
blob58f04b3c8d6280277c202f9e33a58e695b3374e6
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
4 pkgname=python-cmd2
5 pkgver=2.4.3
6 _commit=031832a76b7a9e25d708153085d18d5366ff318d
7 pkgrel=2
8 pkgdesc="A tool for building interactive command line apps"
9 arch=('any')
10 url="https://github.com/python-cmd2/cmd2"
11 license=('MIT')
12 depends=('python-attrs' 'python-colorama' 'python-pyperclip' 'python-wcwidth')
13 makedepends=('git' 'python-setuptools-scm')
14 checkdepends=('python-pytest-cov' 'python-pytest-mock' 'python-pytest-runner' 'python-pytest-xdist'
15               'vi')
16 source=("git+https://github.com/python-cmd2/cmd2.git#commit=$_commit")
17 sha512sums=('SKIP')
19 build() {
20   cd cmd2
21   python setup.py build
24 check() {
25   cd cmd2
26   python setup.py pytest
29 package() {
30   cd cmd2
31   python setup.py install --root="$pkgdir" --optimize=1
34 # vim:set ts=2 sw=2 et: