1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
6 _commit=031832a76b7a9e25d708153085d18d5366ff318d
8 pkgdesc="A tool for building interactive command line apps"
10 url="https://github.com/python-cmd2/cmd2"
12 depends=('python-attrs' 'python-colorama' 'python-pyperclip' 'python-wcwidth')
13 makedepends=('git' 'python-setuptools-scm')
14 checkdepends=('python-pytest-cov' 'python-pytest-mock' 'python-pytest-runner' 'python-pytest-xdist'
16 source=("git+https://github.com/python-cmd2/cmd2.git#commit=$_commit")
26 python setup.py pytest
31 python setup.py install --root="$pkgdir" --optimize=1
34 # vim:set ts=2 sw=2 et: