1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
4 pkgname=python-$_pyname
7 pkgdesc='Python library for calculating contours in 2D quadrilateral grids'
9 url='https://github.com/contourpy/contourpy'
11 makedepends=(python-build python-installer python-setuptools pybind11 python-wheel)
12 depends=(python-numpy)
13 checkdepends=(python-pytest python-matplotlib)
14 optdepends=('python-matplotlib: matplotlib renderer')
15 source=(https://pypi.python.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz)
16 sha256sums=('d8165a088d31798b59e91117d1f5fc3df8168d8b48c4acc10fc0df0d0bdbcc5e')
20 python -m build --wheel --no-isolation
25 python -m venv --system-site-packages test-env
26 test-env/bin/python -m installer dist/*.whl
27 test-env/bin/python -m pytest -v
32 python -m installer --destdir="$pkgdir" dist/*.whl
33 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname