upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-cylp / trunk / PKGBUILD
blob7b04b4bcf71b75178af375b22fe03141f8205126
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Anton Kudelin <kudelin at protonmail dot com>
4 _pyname=cylp
5 pkgname=python-$_pyname
6 pkgver=0.91.6
7 pkgrel=1
8 pkgdesc='A Python interface to CLP, CBC, and CGL to solve LPs and MIPs'
9 arch=(x86_64)
10 url='https://github.com/coin-or/CyLP'
11 license=(EPL)
12 depends=(python-scipy coin-or-cbc)
13 makedepends=(python-build python-installer python-setuptools python-wheel cython)
14 checkdepends=(python-pytest)
15 source=(https://github.com/coin-or/CyLP/archive/v$pkgver/$_pyname-$pkgver.tar.gz)
16 sha256sums=('e05a4db7f86646a0103235d2b9620ec3bb1d88ca34e11319f9feb98ed11e3156')
18 build() {
19   cd CyLP-$pkgver
20   python -m build --wheel --no-isolation --skip-dependency-check
23 check() {
24   cd CyLP-$pkgver
25   python -m venv --system-site-packages test-env
26   test-env/bin/python -m installer dist/*.whl
27 # Prevent from loading the uncompiled cylp
28   mv cylp/tests .
29   rm -r cylp
30 # Many tests segfault https://github.com/coin-or/CyLP/issues/105
31 # test-env/bin/python -m pytest -v'
33   
34 package() {
35   cd CyLP-$pkgver
36   python -m installer --destdir="$pkgdir" dist/*.whl
37   install -Dm755 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname