1 # Maintainer: Bruno Pagani <archange@archlinux.org>
4 pkgname=python-${_pkg,,}
7 pkgdesc="Easy to use python subprocess interface"
9 url="https://github.com/ponty/EasyProcess"
12 makedepends=(python-setuptools)
13 checkdepends=(python-pytest python-pytest-timeout python-entrypoint2
14 python-pillow python-pyvirtualdisplay imagemagick iputils
16 source=(https://files.pythonhosted.org/packages/source/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz)
17 sha256sums=('885898302a57aab948973e8b5d32a4229392b9fb2d986ab1d4ffd590e5ba90ec')
26 # https://github.com/ponty/EasyProcess/issues/24
27 PYTHONPATH="${PWD}"/build/lib/ pytest -vv --color=yes -k 'not test_deadlock_pipe'
28 PYTHONPATH="${PWD}"/build/lib/ EASYPROCESS_USE_TEMP_FILES=0 pytest -vv --color=yes
33 python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=1
34 install -Dm644 LICENSE.txt -t "${pkgdir}"/usr/share/licenses/${pkgname}