1 # Maintainer: Bruno Pagani <archange@archlinux.org>
7 pkgdesc="Easy to use command-line interface for python modules"
9 url="https://github.com/ponty/entrypoint2"
12 makedepends=(python-setuptools)
13 checkdepends=(python-pytest python-easyprocess)
14 source=(https://files.pythonhosted.org/packages/source/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz)
15 #source=(${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
16 sha256sums=('fc0b7fe7b21acdab47a585ab9407ca7e5c4f96cb6888575db6b0ceb91f0e105a')
25 PYTHONPATH="${PWD}"/build/lib/ pytest -vv --color=yes
30 python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=1
31 install -Dm644 LICENSE.txt -t "${pkgdir}"/usr/share/licenses/${pkgname}