upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-entrypoint2 / trunk / PKGBUILD
blobf963aed23bd10f9cb6c805684ab30a4180d3602e
1 # Maintainer: Bruno Pagani <archange@archlinux.org>
3 _pkg=entrypoint2
4 pkgname=python-${_pkg}
5 pkgver=1.1
6 pkgrel=3
7 pkgdesc="Easy to use command-line interface for python modules"
8 arch=(any)
9 url="https://github.com/ponty/entrypoint2"
10 license=(BSD)
11 depends=(python)
12 makedepends=(python-setuptools)
13 checkdepends=(python-pytest python-easyprocess)
14 source=(https://files.pythonhosted.org/packages/source/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz)
15 #source=(${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
16 sha256sums=('fc0b7fe7b21acdab47a585ab9407ca7e5c4f96cb6888575db6b0ceb91f0e105a')
18 build() {
19   cd ${_pkg}-${pkgver}
20   python setup.py build
23 check() {
24   cd ${_pkg}-${pkgver}
25   PYTHONPATH="${PWD}"/build/lib/ pytest -vv --color=yes
28 package() {
29   cd ${_pkg}-${pkgver}
30   python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=1
31   install -Dm644 LICENSE.txt -t "${pkgdir}"/usr/share/licenses/${pkgname}