upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-first / repos / community-any / PKGBUILD
blobdb4f1e1942ad2d52269fb7e7d6510ca04a2bbb5f
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-first
4 pkgver=2.0.2
5 pkgrel=6
6 pkgdesc="Return the first true value of an iterable"
7 url="https://github.com/hynek/first"
8 license=('MIT')
9 arch=('any')
10 depends=('python')
11 makedepends=('python-setuptools')
12 checkdepends=('python-pytest-runner')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/hynek/first/archive/$pkgver.tar.gz")
14 sha512sums=('4d82d4b3ddae8a47ab423b1ab5c281738f0290e428be5ce66ce50ed8110ced656c57a7164a3ca734763db117be437fe32d9d9d9a7cd196296b2ac1c4dd14d675')
16 build() {
17   cd first-$pkgver
18   python setup.py build
21 check() {
22   cd first-$pkgver
23   python setup.py pytest
26 package() {
27   cd first-$pkgver
28   python setup.py install --root="$pkgdir" --optimize=1
30   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/