1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-flask-debug
6 pkgdesc="A small debugging helper for Flask"
7 url="https://github.com/mbr/flask-debug"
10 depends=('python-flask' 'python-inflection')
11 makedepends=('python-setuptools')
12 checkdepends=('python-pytest-runner')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/mbr/flask-debug/archive/$pkgver.tar.gz")
14 sha512sums=('7bc1cf9f88f28e2ca5a24c1454dcdb4e2a450eff3c00329f299c3840032e0803079f565652974f4c3a0e5aac443365ce47a3d2c2fee8e21e2e0c7150367e8816')
17 cd Flask-Debug-$pkgver
22 cd Flask-Debug-$pkgver
23 python setup.py pytest
27 cd Flask-Debug-$pkgver
28 python setup.py install --root="$pkgdir" --optimize=1
29 install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE