upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-flit-scm / trunk / PKGBUILD
blob99db0480cb0a2671d1e729777c726043a3d7040e
1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
2 # Contributor: Padraic Fanning <fanninpm AT miamioh DOT edu>
4 _name=flit_scm
5 pkgname=python-${_name//_/-}
6 pkgver=1.7.0
7 pkgrel=4
8 pkgdesc='A PEP 518 backend using setuptools_scm to generate a version file, then flit to build'
9 arch=(any)
10 url="https://gitlab.com/WillDaSilva/$_name"
11 license=(MIT)
12 depends=(python
13          python-flit-core
14          python-setuptools-scm)
15 makedepends=(python-{build,installer,wheel})
16 _archive="$_name-$pkgver"
17 source=("$_archive.tar.gz::$url/-/archive/$pkgver/$_archive.tar.gz")
18 sha256sums=('05a267d77f6f8ca50a053786fe3c1a74f7222f2955292f2e6c03d2d064a141dc')
20 build() {
21         cd "$_archive"
22         export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
23         python -m build -wn
26 package() {
27         cd "$_archive"
28         export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
29         python -m installer -d "$pkgdir" dist/*.whl
30         install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE