1 # Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
2 # Maintainer: Morten Linderud <foxboron@archlinux.org>
3 # Contributor: Kaizhao Zhang <zhangkaizhao@gmail.com>
5 pkgname=python-google-api-core
8 pkgdesc="Google API client core library"
10 url="https://github.com/googleapis/googleapis"
12 depends=('python-pytz' 'python-requests' 'python-googleapis-common-protos' 'python-google-auth')
13 makedepends=('python-setuptools')
14 optdepends=('python-grpcio: for grpc support')
15 source=("https://files.pythonhosted.org/packages/source/g/google-api-core/google-api-core-${pkgver}.tar.gz")
16 sha256sums=('4b9bb5d5a380a0befa0573b302651b8a9a89262c1730e37bf423cec511804c22')
19 cd "google-api-core-${pkgver}"
24 cd "google-api-core-${pkgver}"
25 python setup.py install --root="$pkgdir" --optimize=1
26 chmod -R a+r "$pkgdir"/usr/lib/python*/site-packages/google_api_core*.egg-info/