upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-guzzle-sphinx-theme / trunk / PKGBUILD
blob5dd2899df9ec4fb7a86c5ee29b32efe212f3c6ca
1 # Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
2 # Contributor: Chris Severance aur.severach AatT spamgourmet.com
4 pkgname=python-guzzle-sphinx-theme
5 _pkgname=guzzle_sphinx_theme
6 pkgver=0.7.11
7 pkgrel=11
8 pkgdesc='Sphinx theme used by Guzzle'
9 arch=('any')
10 url="https://github.com/guzzle/${_pkgname}"
11 license=('custom')
12 makedepends=('python-distribute')
13 depends=('python' 'python-sphinx>=1.1.3')
14 source=("${_pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
15 sha256sums=('f5f0e3d541c09ace912e0fa75dafd46f5a54314a929913c7de9709e677d5aa09')
17 build() {
18   cd "${_pkgname}-$pkgver"
19   python setup.py build
22 package() {
23   cd "${_pkgname}-$pkgver"
24   python setup.py install --root="${pkgdir}" --optimize=1
25   install -Dpm644 'README.rst' 'requirements.txt' -t "${pkgdir}/usr/share/doc/${pkgname}/"
26   install -Dpm644 'LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"