upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-hid / trunk / PKGBUILD
blobde61359a1ef07a359066589be3a39317cefa700b
1 # Maintainer: Morten Linderud <foxboron@archlinux.org>
2 # Contributor: Thomas Weißschuh <thomas t-8ch de>
4 pkgname=python-hid
5 pkgver=1.0.4
6 pkgrel=8
7 _pkgname=${pkgname#python-}
8 pkgdesc="Python hidapi bindings in ctypes (aka pyhidapi)"
9 arch=(any)
10 url="https://github.com/apmorton/pyhidapi"
11 license=(MIT)
12 depends=(hidapi python)
13 conflicts=(python-hidapi)
14 makedepends=(python-setuptools)
15 source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
16 sha256sums=('f61b0382f37a334bc8ba8604bc84b94875ee4f594fbbaf82b2c3b3e827883fc1')
18 build() {
19   cd "$_pkgname-$pkgver"
20   python setup.py build
23 package() {
24   cd "$_pkgname-$pkgver"
25   python setup.py install --skip-build -O1 --root="$pkgdir"