1 # Maintainer: Jelle van der Waa <jelle@vdwaa.nl>
2 # Contributor: Grey Christoforo <first name [at] last name [dot] net>
7 pkgdesc="Iterative JSON parser with Pythonic interface"
9 url="https://github.com/ICRAR/ijson"
11 depends=('python' 'yajl')
12 makedepends=('python-setuptools' 'python-pytest')
13 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ICRAR/ijson/archive/v${pkgver}.tar.gz")
14 sha256sums=('20e64b3786bc65f45e40e77413fdcd3e3b692ecbd361ef13d2319655f5b66675')
23 local python_version=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
24 PYTHONPATH="$PWD/build/lib.linux-$CARCH-${python_version}" pytest
29 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
30 install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE.txt