upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-ijson / trunk / PKGBUILD
blob2baa056d665fd37bdd8599024d6765d88f448d8b
1 # Maintainer: Jelle van der Waa <jelle@vdwaa.nl>
2 # Contributor: Grey Christoforo <first name [at] last name [dot] net>
4 pkgname=python-ijson
5 pkgver=3.2.0
6 pkgrel=1
7 pkgdesc="Iterative JSON parser with Pythonic interface"
8 arch=(x86_64)
9 url="https://github.com/ICRAR/ijson"
10 license=('BSD')
11 depends=('python' 'yajl')
12 makedepends=('python-setuptools' 'python-pytest')
13 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ICRAR/ijson/archive/v${pkgver}.tar.gz")
14 sha256sums=('20e64b3786bc65f45e40e77413fdcd3e3b692ecbd361ef13d2319655f5b66675')
16 build() {
17   cd ijson-$pkgver
18   python setup.py build
21 check() {
22   cd ijson-$pkgver
23   local python_version=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
24   PYTHONPATH="$PWD/build/lib.linux-$CARCH-${python_version}" pytest
27 package(){
28   cd ijson-$pkgver
29   python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
30   install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE.txt
33 # vim:ts=2:sw=2:et: