upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-install / trunk / PKGBUILD
blobefb72859c51a6e8847a66fe14e3406f550012e8d
1 # Maintainer: Filipe Laíns (FFY00) <lains@archlinux.org>
3 _pkgname=install
4 pkgname=python-$_pkgname
5 pkgver=0.0.3
6 pkgrel=3
7 pkgdesc='A simple, correct PEP427 wheel installer'
8 arch=('any')
9 url='https://github.com/FFY00/python-install'
10 license=('GPL')
11 depends=('python')
12 makedepends=('git' 'python-setuptools')
13 source=("git+$url#tag=$pkgver?signed"
14         'git+https://github.com/pradyunsg/installer.git')
15 validpgpkeys=('3DCE51D60930EBA47858BA4146F633CBB0EB4BF2') # Filipe Laíns (FFY00) <lains@archlinux.org>
16 sha512sums=('SKIP'
17             'SKIP')
19 prepare() {
20   cd $pkgname
22   git submodule init
23   git config submodule.install/_vendor/installer.url "$srcdir"/installer
24   git submodule update
27 build() {
28   cd $pkgname
30   python setup.py build
33 package() {
34   cd $pkgname
36   python setup.py install --root="$pkgdir" --optimize=1 --skip-build