upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-ipywidgets / trunk / PKGBUILD
blobf6940db9ce1bc707df2a38796e8cfaf9c84228a8
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Kyle Keen <keenerd@gmail.com>
4 pkgname=python-ipywidgets
5 _pipname=ipywidgets
6 pkgver=8.0.6
7 pkgrel=4
8 pkgdesc='IPython HTML widgets for Jupyter'
9 arch=(any)
10 url='https://github.com/ipython/ipywidgets'
11 license=(BSD)
12 depends=(python-ipykernel python-jsonschema python-ipython-genutils)
13 makedepends=(python-build python-installer python-setuptools python-wheel)
14 optdepends=('jupyterlab-widgets: widgets for Jupyter lab' 'jupyter-widgetsnbextension: widgets for the legacy notebook')
15 checkdepends=(python-pytest python-pytz)
16 source=(https://pypi.io/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz)
17 sha256sums=('de7d779f2045d60de9f6c25f653fdae2dba57898e6a1284494b3ba20b6893bb8')
19 build() {
20   cd ipywidgets-$pkgver
21   python -m build --wheel --no-isolation
24 check() {
25   cd ipywidgets-$pkgver
26   pytest -v
29 package() {
30   cd ipywidgets-$pkgver
31   python -m installer --destdir="$pkgdir" dist/*.whl
32   install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"