1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Kyle Keen <keenerd@gmail.com>
4 pkgname=python-ipywidgets
8 pkgdesc='IPython HTML widgets for Jupyter'
10 url='https://github.com/ipython/ipywidgets'
12 depends=(python-ipykernel python-jsonschema python-ipython-genutils)
13 makedepends=(python-build python-installer python-setuptools python-wheel)
14 optdepends=('jupyterlab-widgets: widgets for Jupyter lab' 'jupyter-widgetsnbextension: widgets for the legacy notebook')
15 checkdepends=(python-pytest python-pytz)
16 source=(https://pypi.io/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz)
17 sha256sums=('de7d779f2045d60de9f6c25f653fdae2dba57898e6a1284494b3ba20b6893bb8')
21 python -m build --wheel --no-isolation
31 python -m installer --destdir="$pkgdir" dist/*.whl
32 install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"