upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-jsonschema-spec / trunk / PKGBUILD
blob5fe3ef831264d209cea8b7c9ef48bbfd2b836366
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-jsonschema-spec
4 pkgver=0.1.3
5 pkgrel=1
6 pkgdesc="JSONSchema Spec with object-oriented paths"
7 url="https://github.com/p1c2u/jsonschema-spec"
8 license=('Apache')
9 arch=('any')
10 depends=('python-jsonschema' 'python-pathable' 'python-yaml' 'python-typing_extensions')
11 makedepends=('python-build' 'python-installer' 'python-poetry-core')
12 checkdepends=('python-pytest')
13 source=("https://github.com/p1c2u/jsonschema-spec/archive/$pkgver/$pkgname-$pkgver.tar.gz")
14 sha512sums=('95465c43b842289ed28dd78ec06614d77b2bbf7d9d69e5dc4b89008740d0cc85e5b3319acd66d0142b533425e8f150c4edbbf15b7f8e3bdefb28b81193a13432')
16 prepare() {
17   cd jsonschema-spec-$pkgver
18   sed -i '/--cov/d' pyproject.toml
21 build() {
22   cd jsonschema-spec-$pkgver
23   python -m build -wn
26 check() {
27   cd jsonschema-spec-$pkgver
28   PYTHONPATH="$PWD" pytest
31 package() {
32   cd jsonschema-spec-$pkgver
33   python -m installer -d "$pkgdir" dist/*.whl