upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-klein / repos / community-any / PKGBUILD
blobcd95ed824b0d055bdd15b1a24125df02fbee1103
1 # Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
2 # Contributor: xRemaLx <anton.komolov@gmail.com>
4 pkgname=python-klein
5 # https://github.com/twisted/klein/blob/trunk/NEWS.rst
6 pkgver=23.5.0
7 pkgrel=1
8 arch=(any)
9 pkgdesc='A web micro-framework built on werkzeug and twisted.web'
10 url='https://github.com/twisted/klein'
11 license=(MIT)
12 depends=(python python-attrs python-hyperlink python-incremental
13          python-tubes python-twisted python-werkzeug python-zope-interface
14          # Detected by namcap and not declared in setup.py
15          python-constantly)
16 makedepends=(python-setuptools)
17 checkdepends=(python-hypothesis python-treq python-pytest)
18 source=("https://github.com/twisted/klein/archive/$pkgver/klein-$pkgver.tar.gz")
19 sha512sums=('ebfd50989bec653cb0997d5d58cd9071e1bd1690566f1892ca3a04511dfe1a64dc790859d955d69aa1757f77f049278bd628025fc2b596d153b7208d3007f0bc')
21 build() {
22   cd klein-$pkgver
23   python setup.py build
26 check() {
27   cd klein-$pkgver
28   pytest src/klein/test
31 package() {
32   cd klein-$pkgver
33   python setup.py install --root="$pkgdir" --optimize=1 --skip-build
34   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname