upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-levenshtein / trunk / PKGBUILD
blob5fe8c321e0eca20018039ecd83b60e790eb24f31
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Thomas S Hatch <thatch45@gmail.com>
3 # Contributor: shamrok <szamrok@gmail.com>
4 # Contributor: scj <scj archlinux us>
6 pkgname=python-levenshtein
7 pkgver=0.21.0
8 pkgrel=2
9 pkgdesc="Python extension for computing string edit distances and similarities"
10 url="https://pypi.python.org/pypi/python-Levenshtein/"
11 license=('GPL')
12 arch=('x86_64')
13 depends=('python-rapidfuzz')
14 makedepends=('python-scikit-build' 'cython' 'rapidfuzz-cpp')
15 checkdepends=('python-pytest')
16 #source=("https://files.pythonhosted.org/packages/source/L/Levenshtein/Levenshtein-$pkgver.tar.gz")
17 source=("https://github.com/maxbachmann/Levenshtein/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
18 sha512sums=('bb1cf70497e89db5b427eb4ac79708d205fc9edfc9588d30c63ef6e3e77b9369c8892edc31c32cb135d54947e8eedb770d06a7d5c6f8743d44378d7d1a12d459')
20 build() {
21   cd Levenshtein-$pkgver
22   python setup.py build
25 check() {
26   cd Levenshtein-$pkgver
27   PYTHONPATH=`echo "$PWD"/_skbuild/linux-x86_64-*/setuptools/lib.linux-x86_64-*` \
28   pytest
31 package() {
32   cd Levenshtein-$pkgver
33   python setup.py install -O1 --root="$pkgdir"