upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-marshmallow-sqlalchemy / trunk / PKGBUILD
blob43d9ad9d415878a7a261151412c3b34bf232916e
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=python-marshmallow-sqlalchemy
4 pkgver=0.29.0
5 pkgrel=2
6 pkgdesc='SQLAlchemy integration with marshmallow'
7 url=https://marshmallow-sqlalchemy.readthedocs.io/
8 arch=(any)
9 license=(MIT)
10 depends=(
11   python-marshmallow
12   python-sqlalchemy
14 makedepends=(
15   git
16   python-setuptools
18 _tag=bafce3319a792768d946e536f066074e24f6a2fb
19 source=(git+https://github.com/marshmallow-code/marshmallow-sqlalchemy.git#tag=${_tag})
20 sha256sums=(SKIP)
22 pkgver() {
23   cd marshmallow-sqlalchemy
25   git describe --tags
28 build() {
29   cd marshmallow-sqlalchemy
31   python setup.py build
34 package() {
35   cd marshmallow-sqlalchemy
37   python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
38   install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/python-marshmallow-sqlalchemy/
41 # vim: ts=2 sw=2 et: