1 # Maintainer: Jelle van der Waa <jelle@archlinux.org>
3 pkgname=python-meilisearch
6 pkgdesc='Python client for MeiliSearch API'
9 url='https://pypi.org/project/meilisearch/'
10 depends=(python python-requests python-camel-converter python-pydantic)
11 makedepends=(python-setuptools python-build python-installer python-wheel)
12 checkdepends=(python-pytest python-pytest-ordering)
13 source=(${pkgname}-${pkgver}.tar.gz::https://github.com/meilisearch/meilisearch-python/archive/v${pkgver}.tar.gz)
14 sha512sums=('f03102bec75f3132d49b3e550fdc978da2cd09d9667280afd1797e72ef429279970cd09f31399e9e0c27dddce18d0a9aad2d2eba24867a7b9fe49831e9f07ade')
17 cd "meilisearch-python-${pkgver}"
18 python -m build --wheel --no-isolation
22 # requires running meilisearch https://github.com/meilisearch/meilisearch-python/blob/master/.github/workflows/test.yml#L20
23 cd "meilisearch-python-${pkgver}"
28 cd "meilisearch-python-${pkgver}"
30 python -m installer --destdir="$pkgdir" dist/*.whl
32 install -D -m644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"