upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-moreorless / trunk / PKGBUILD
blobbe58de838cb8857004bed9394799a8a2a668a60c
1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
3 _pkgname=moreorless
4 pkgname=python-moreorless
5 pkgver=0.4.0
6 pkgrel=6
7 pkgdesc='Python diff wrapper'
8 arch=(any)
9 url="https://github.com/thatch/$_pkgname"
10 license=(MIT)
11 depends=(python)
12 makedepends=(python-{build,installer,wheel}
13              python-setuptools-scm)
14 _archive="$_pkgname-$pkgver"
15 source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_archive.tar.gz")
16 sha256sums=('85e19972c1a0b3a49f8543914f57bd83f6e1b10df144d5b97b8c5e9744d9c08c')
17 b2sums=('60e810352e13d4723b138b6bad78536994c9430b51feb5114d44738515e890143b2d69678bb0d2fa87c51e0918b4ef15a084bd466898f41a0055ca3f1372b619')
19 build(){
20     cd "$_archive"
21     python -m build -wn
24 package() {
25     cd "$_archive"
26     python -m installer -d "$pkgdir" dist/*.whl