1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
4 pkgname=python-${_pyname}
7 pkgdesc='FLIRT signatures for python'
8 url='https://github.com/thebabush/nampa'
11 depends=('python' 'python-future')
12 makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
13 checkdepends=('python-pytest')
14 source=("${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
15 sha512sums=('899ee2786b0d1739f5d9836310e13c7fdc46df14259491acc480db69f291d6c9934d059064a54798fecab84a9e4a731ada71105dee67b967e93d3cb4435a3387')
16 b2sums=('73122bb669f825fd1b50f6fba1b58f0c1232c404590b7ada652e3142bd4bf74aae21dcb3362c6c9ec7bd1904e13bf1654c2eb3e8ec68332f1a92660bee2ac249')
19 cd ${_pyname}-${pkgver}
20 export EXTRA_CFLAGS="${CFLAGS} ${CPPFLAGS}"
21 python -m build --wheel --no-isolation
25 cd ${_pyname}-${pkgver}
26 PYTHONPATH=build/lib pytest
30 cd ${_pyname}-${pkgver}
31 python -m installer --destdir="$pkgdir" dist/*.whl
32 install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
33 install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"