upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-ndindex / repos / community-any / PKGBUILD
blobbb0f02eb7b6d12b21551d1ea2a8827f417cf078d
1 # Maintainer:
3 _pyname=ndindex
4 pkgname=python-$_pyname
5 pkgver=1.7
6 pkgrel=1
7 pkgdesc='Library for manipulating indices of ndarrays'
8 arch=(any)
9 url='https://quansight-labs.github.io/ndindex/'
10 license=(MIT)
11 depends=(python-numpy)
12 makedepends=(python-build python-installer python-setuptools python-wheel)
13 checkdepends=(python-pytest-cov python-hypothesis python-pyflakes)
14 source=(https://github.com/Quansight-Labs/ndindex/archive/$pkgver/$pkgname-$pkgver.tar.gz)
15 sha256sums=('388f45290393262b69ee440053bfe1664cdac6a125b29c2ea2569cdc3943dbbe')
17 prepare() {
18   cd $_pyname-$pkgver
19   sed -e 's|--flakes||' -i pytest.ini
22 build() {
23   cd $_pyname-$pkgver
24   python -m build --wheel --no-isolation
27 check() {
28   cd $_pyname-$pkgver
29   pytest -v
32 package() {
33   cd $_pyname-$pkgver
34   python -m installer --destdir="$pkgdir" dist/*.whl