1 # Maintainer: Giovanni Scafora <giovanni@archlinux.org>
2 # Contributor: Gergely Imreh <imrehg(at)gmail(dot)com>
3 # Contributor: Ghost of Kendo <ghostofkendo at gmail dot com>
5 pkgname=python-netifaces
8 pkgdesc="Portable module to access network interface information in Python"
10 url="https://alastairs-place.net/netifaces/"
13 makedepends=('python-setuptools')
14 source=("https://pypi.io/packages/source/n/netifaces/netifaces-${pkgver}.tar.gz")
15 sha512sums=('a53110efb78c89c4d72d002104866253a4c085dd27ff9f41d4cfe3811cc5619e7585ceda4e91e83cdd0645c40c745c61d205708ee9a34427b35f437a48f148e5')
18 cd "${srcdir}/netifaces-${pkgver}"
24 cd "${srcdir}/netifaces-${pkgver}"
26 python setup.py install --root "${pkgdir}" --skip-build
28 # Install license, that is inside the readme file
29 install -Dm644 README.rst "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"