1 # Maintainer: David Runge <dvzrv@archlinux.org>
7 pkgdesc="Python tool for Nitrokeys' firmware update"
9 url="https://github.com/Nitrokey/nkdfu"
11 depends=(python-fire python-tqdm python-intelhex python-libusb1)
12 makedepends=(python-build python-flit-core python-installer python-wheel)
13 source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
14 sha256sums=('f25f75ddd382c47285b6943cde9f51577b1496ed284f93d58b5e054ae609f5f8')
15 b2sums=('8251d54f02d7fa114a00037409cbc35fd0991d45465351dd3247c70d52aa299e260bacca69aa7e8958b9b50996141ee589c3c663c84523ff7488911ee0e3b9b3')
19 python -m build --wheel --no-isolation
24 python -m installer --destdir="$pkgdir" dist/*.whl
25 install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"