upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-novaclient / repos / community-any / PKGBUILD
blob5df1cb64312ad643c8a50d868aece04aa98c1e91
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
4 pkgname=python-novaclient
5 pkgver=18.3.0
6 _commit=85e4f08309490fa2ab6f0b581b3d645d2dbb5c4b
7 pkgrel=3
8 pkgdesc="Client library for OpenStack Compute API"
9 arch=('any')
10 url="https://docs.openstack.org/python-novaclient/latest/"
11 license=('Apache')
12 depends=('python-six' 'python-pbr' 'python-babel' 'python-prettytable' 'python-keystoneauth1'
13          'python-requests' 'python-iso8601' 'python-oslo-utils' 'python-oslo-i18n'
14          'python-oslo-serialization')
15 makedepends=('git' 'python-setuptools')
16 checkdepends=('python-oslotest' 'python-osprofiler' 'python-requests-mock' 'python-ddt' 'python-stestr' 'python-testscenarios')
17 source=("git+https://github.com/openstack/python-novaclient.git#commit=$_commit")
18 sha512sums=('SKIP')
20 build() {
21   cd python-novaclient
22   python setup.py build
25 check() {
26   cd python-novaclient
27   stestr run
30 package() {
31   cd python-novaclient
32   python setup.py install --root="$pkgdir" --optimize=1