upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-pandas / trunk / PKGBUILD
blob4d56aa2de5627c0ec9ec334afae828873a37fc87
1 # Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
2 # Maintainer: Morten Linderud <foxboron@archlinux.org>
3 # Maintainer: Bruno Pagani <archange@archlinux.org>
4 # Contributor: Keith Hughitt <khughitt@umd.edu>
6 pkgname=python-pandas
7 pkgver=1.5.3
8 pkgrel=3
9 pkgdesc='High-performance, easy-to-use data structures and data analysis tools for Python'
10 arch=(x86_64)
11 url="https://pandas.pydata.org/"
12 license=(BSD)
13 depends=('python-numpy' 'python-dateutil' 'python-pytz' 'python-setuptools')
14 makedepends=('cython')
15 optdepends=(
16     'python-pandas-datareader: pandas.io.data replacement (recommended)'
17     'python-numexpr: accelerating certain numerical operations (recommended)'
18     'python-bottleneck: accelerating certain types of nan evaluations (recommended)'
19     'python-matplotlib: plotting'
20     'python-jinja: conditional formatting with DataFrame.style'
21     'python-tabulate: printing in Markdown-friendly format'
22     'python-scipy: miscellaneous statistical functions'
23     'python-numba: alternative execution engine'
24     'python-xarray: pandas-like API for N-dimensional data'
25     'python-xlrd: Excel XLS input'
26     'python-xlwt: Excel XLS output'
27     'python-openpyxl: Excel XLSX input/output'
28     'python-xlsxwriter: alternative Excel XLSX output'
29     # 'python-pyxlsb: XLSB input' (nowhere)
30     'python-beautifulsoup4: read_html function (in any case)'
31     'python-html5lib: read_html function (and/or python-lxml)'
32     'python-lxml: read_xml, to_xml and read_html function (and/or python-html5lib)'
33     'python-sqlalchemy: SQL database support'
34     'python-psycopg2: PostgreSQL engine for sqlalchemy'
35     'python-pymysql: MySQL engine for sqlalchemy'
36     'python-pytables: HDF5-based reading / writing'
37     'python-blosc: for msgpack compression using blosc'
38     'zlib: compression for msgpack'
39     # 'python-fastparquet: Parquet reading / writing' (in the AUR)
40     'python-pyarrow: Parquet, ORC and feather reading/writing'
41     # 'python-pyreadstat: SPSS files reading' (in the AUR)
42     'python-fsspec: handling files aside from local and HTTP'
43     # 'python-gcsfs: Google Cloud Storage access' (in the AUR)
44     # 'python-pandas-gbq: Google BigQuery access' (nowhere)
45     # 'python-s3fs: Amazon S3 access' (in the AUR)
46     'python-pyqt5: read_clipboard function (only one needed)'
47     'python-qtpy: read_clipboard function (only one needed)'
48     'xclip: read_clipboard function (only one needed)'
49     'xsel: read_clipboard function (only one needed)'
50     'python-brotli: Brotli compression'
51     'python-snappy: Snappy compression'
52     'python-zstandard: Zstandard (zstd) compression'
54 checkdepends=(
55     'python-pytest'
56     'python-pytest-asyncio'
57     'python-pytest-xdist'
58     'python-hypothesis'
59     'python-pandas-datareader'
60     'python-numexpr'
61     'python-bottleneck'
62     'python-matplotlib'
63     'python-jinja'
64     'python-tabulate'
65     'python-scipy'
66     'python-numba'
67     'python-xarray'
68     'python-xlrd'
69     'python-xlwt'
70     'python-openpyxl'
71     'python-xlsxwriter'
72     # 'python-pyxlsb' (nowhere)
73     'python-beautifulsoup4'
74     'python-html5lib'
75     'python-lxml'
76     'python-sqlalchemy'
77     'python-psycopg2'
78     'python-pymysql'
79     'python-pytables'
80     'python-blosc'
81     'zlib'
82     # 'python-fastparquet' (in the AUR)
83     'python-pyarrow'
84     # 'python-pyreadstat' (in the AUR)
85     'python-fsspec'
86     # 'python-gcsfs' (in the AUR)
87     # 'python-pandas-gbq' (nowhere)
88     # 'python-s3fs' (in the AUR)
89     'python-pyqt5'
90     'python-qtpy'
91     'xclip'
92     'xsel'
93     'python-brotli'
94     'python-snappy'
95     'python-zstandard'
96     'python-dask'
97     'python-toolz'
98     'python-cftime'
99     'python-statsmodels'
100     'python-scikit-learn'
101     'python-seaborn'
102     'python-geopandas'
103     'python-odfpy'
104     'ipython'
105     'python-botocore'
106     'python-numba'
108 # No test data in upstream crafted tarball
109 #source=(https://github.com/pandas-dev/pandas/releases/download/v${pkgver}/pandas-${pkgver}.tar.gz)
110 source=(https://github.com/pandas-dev/pandas/archive/refs/tags/v${pkgver}/${pkgname}-${pkgver}.tar.gz
111         fix-pyarrow-10.patch)
112 sha256sums=('d8abf9c2bf33cac75b28f32c174c29778414eb249e5e2ccb69b1079b97a8fc66'
113             '65008439d0eeef47ef4dca98ef7469b548f3d2f3b1666809cb846b84b07c05f4')
115 prepare() {
116   cd pandas-${pkgver}
117   # https://github.com/pandas-dev/pandas/commit/4878dfe551da2fa8e2bc33e774b595f099bfa74e
118   patch -p1 < ../fix-pyarrow-10.patch
121 build() {
122   cd pandas-${pkgver}
123   python setup.py build_ext --inplace
124   python setup.py build
127 check() {
128   cd pandas-${pkgver}
129   # TODO: Revisit after new release with better python3.11 support
130   # pytest pandas --skip-slow --skip-network --skip-db -m "not clipboard and not single_cpu" -n 4 -r sxX || true
133 package() {
134   cd pandas-${pkgver}
135   python setup.py install --skip-build --root="$pkgdir" --optimize=1
136   install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE