1 # Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
2 # Maintainer: Morten Linderud <foxboron@archlinux.org>
3 # Maintainer: Bruno Pagani <archange@archlinux.org>
4 # Contributor: Keith Hughitt <khughitt@umd.edu>
9 pkgdesc='High-performance, easy-to-use data structures and data analysis tools for Python'
11 url="https://pandas.pydata.org/"
13 depends=('python-numpy' 'python-dateutil' 'python-pytz' 'python-setuptools')
14 makedepends=('cython')
16 'python-pandas-datareader: pandas.io.data replacement (recommended)'
17 'python-numexpr: accelerating certain numerical operations (recommended)'
18 'python-bottleneck: accelerating certain types of nan evaluations (recommended)'
19 'python-matplotlib: plotting'
20 'python-jinja: conditional formatting with DataFrame.style'
21 'python-tabulate: printing in Markdown-friendly format'
22 'python-scipy: miscellaneous statistical functions'
23 'python-numba: alternative execution engine'
24 'python-xarray: pandas-like API for N-dimensional data'
25 'python-xlrd: Excel XLS input'
26 'python-xlwt: Excel XLS output'
27 'python-openpyxl: Excel XLSX input/output'
28 'python-xlsxwriter: alternative Excel XLSX output'
29 # 'python-pyxlsb: XLSB input' (nowhere)
30 'python-beautifulsoup4: read_html function (in any case)'
31 'python-html5lib: read_html function (and/or python-lxml)'
32 'python-lxml: read_xml, to_xml and read_html function (and/or python-html5lib)'
33 'python-sqlalchemy: SQL database support'
34 'python-psycopg2: PostgreSQL engine for sqlalchemy'
35 'python-pymysql: MySQL engine for sqlalchemy'
36 'python-pytables: HDF5-based reading / writing'
37 'python-blosc: for msgpack compression using blosc'
38 'zlib: compression for msgpack'
39 # 'python-fastparquet: Parquet reading / writing' (in the AUR)
40 'python-pyarrow: Parquet, ORC and feather reading/writing'
41 # 'python-pyreadstat: SPSS files reading' (in the AUR)
42 'python-fsspec: handling files aside from local and HTTP'
43 # 'python-gcsfs: Google Cloud Storage access' (in the AUR)
44 # 'python-pandas-gbq: Google BigQuery access' (nowhere)
45 # 'python-s3fs: Amazon S3 access' (in the AUR)
46 'python-pyqt5: read_clipboard function (only one needed)'
47 'python-qtpy: read_clipboard function (only one needed)'
48 'xclip: read_clipboard function (only one needed)'
49 'xsel: read_clipboard function (only one needed)'
50 'python-brotli: Brotli compression'
51 'python-snappy: Snappy compression'
52 'python-zstandard: Zstandard (zstd) compression'
56 'python-pytest-asyncio'
59 'python-pandas-datareader'
72 # 'python-pyxlsb' (nowhere)
73 'python-beautifulsoup4'
82 # 'python-fastparquet' (in the AUR)
84 # 'python-pyreadstat' (in the AUR)
86 # 'python-gcsfs' (in the AUR)
87 # 'python-pandas-gbq' (nowhere)
88 # 'python-s3fs' (in the AUR)
100 'python-scikit-learn'
108 # No test data in upstream crafted tarball
109 #source=(https://github.com/pandas-dev/pandas/releases/download/v${pkgver}/pandas-${pkgver}.tar.gz)
110 source=(https://github.com/pandas-dev/pandas/archive/refs/tags/v${pkgver}/${pkgname}-${pkgver}.tar.gz
111 fix-pyarrow-10.patch)
112 sha256sums=('d8abf9c2bf33cac75b28f32c174c29778414eb249e5e2ccb69b1079b97a8fc66'
113 '65008439d0eeef47ef4dca98ef7469b548f3d2f3b1666809cb846b84b07c05f4')
117 # https://github.com/pandas-dev/pandas/commit/4878dfe551da2fa8e2bc33e774b595f099bfa74e
118 patch -p1 < ../fix-pyarrow-10.patch
123 python setup.py build_ext --inplace
124 python setup.py build
129 # TODO: Revisit after new release with better python3.11 support
130 # pytest pandas --skip-slow --skip-network --skip-db -m "not clipboard and not single_cpu" -n 4 -r sxX || true
135 python setup.py install --skip-build --root="$pkgdir" --optimize=1
136 install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE