upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-pgpy / trunk / PKGBUILD
blobac87a6d1090373f6c694077c6aeab4d0e38ed105
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: James Morris <jmorris@securityinnovation.com>
4 pkgname=python-pgpy
5 pkgver=0.6.0
6 pkgrel=2
7 pkgdesc='Pretty Good Privacy for Python'
8 arch=('any')
9 license=('BSD')
10 url='https://github.com/SecurityInnovation/PGPy'
11 depends=(
12   'python'
13   'python-cryptography'
14   'python-pyasn1'
16 makedepends=(
17   'git'
18   'python-setuptools'
20 checkdepends=(
21   'python-pytest'
22   'python-pytest-order'
24 _commit='a0e56ff79df37652208002dba9f37e29f451c8ac'
25 source=("$pkgname::git+$url.git#commit=$_commit")
26 b2sums=('SKIP')
28 pkgver() {
29   cd "$pkgname"
31   git describe --tags | sed 's/^v//'
34 build() {
35   cd "$pkgname"
37   python setup.py build
40 check() {
41   cd "$pkgname"
43   pytest
46 package() {
47   cd "$pkgname"
49   python setup.py install --root="$pkgdir" --optimize=1 --skip-build
51   install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE