upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-pluggy / repos / community-any / PKGBUILD
bloba7a9a861462c663061431ca6c81dc7305f14d072
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-pluggy
4 pkgver=1.0.0
5 _commit=4259fdd799d64f953631e47ddcb69c3074a15c13
6 pkgrel=4
7 pkgdesc="Plugin and hook calling mechanisms for python"
8 arch=('any')
9 url="https://github.com/pytest-dev/pluggy"
10 license=('MIT')
11 depends=('python')
12 makedepends=('git' 'python-setuptools-scm')
13 checkdepends=('python-pytest')
14 source=("git+https://github.com/pytest-dev/pluggy.git#commit=$_commit")
15 sha512sums=('SKIP')
17 build() {
18   cd pluggy
19   python setup.py build
22 check() {
23   cd pluggy
24   PYTHONPATH="$PWD"/src pytest
27 package() {
28   cd pluggy
29   python setup.py install -O1 --root "$pkgdir"
30   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/