upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-prefixed / repos / community-any / PKGBUILD
blob58113536eb98e3ce4b61f72668735024a829c753
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Alan <alan1world@googlemail.com>
4 pkgname=python-prefixed
5 pkgver=0.7.0
6 pkgrel=2
7 pkgdesc='Prefixed alternative numeric library'
8 arch=(any)
9 url=https://github.com/Rockhopper-Technologies/prefixed
10 license=(MPL2)
11 depends=(python)
12 makedepends=(
13   git
14   python-build
15   python-installer
16   python-setuptools
17   python-wheel
19 _tag=15e529d4b5fd943cde4ee80eb5010bdaa8e0611c
20 source=(git+https://github.com/Rockhopper-Technologies/prefixed.git#tag=${_tag})
21 b2sums=(SKIP)
23 build() {
24   cd prefixed
25   python -m build --wheel --no-isolation
28 package(){
29   cd prefixed
30   python -m installer --destdir="${pkgdir}" dist/*.whl
31   install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/python-prefixed/
34 # vim: ts=2 sw=2 et: