1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Guillaume Horel <guillaume.horel@gmail.com>
4 pkgname=python-psycopg-pool
5 # source is shared with python-psycopg package, hence the weird naming
6 _pkgname=python-psycopg
9 pkgdesc='Connection pool for psycopg'
11 url='https://www.psycopg.org/psycopg3/'
13 depends=('python' 'python-psycopg')
21 _commit='0b4763dfb00dbbbf6f0d81b1fc9a7ddf98c52345'
22 source=("$_pkgname::git+https://github.com/psycopg/psycopg.git#commit=$_commit")
28 git describe --tags | sed 's/^pool-//'
32 cd "$_pkgname/psycopg_pool"
34 python -m build --wheel --no-isolation
38 cd "$_pkgname/psycopg_pool"
40 python -m installer --destdir="$pkgdir" dist/*.whl