upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-psycopg-pool / trunk / PKGBUILD
blob6cc564fec8edd407553ce1d1c3c63aa7c6b09e22
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Guillaume Horel <guillaume.horel@gmail.com>
4 pkgname=python-psycopg-pool
5 # source is shared with python-psycopg package, hence the weird naming
6 _pkgname=python-psycopg
7 pkgver=3.1.7
8 pkgrel=1
9 pkgdesc='Connection pool for psycopg'
10 arch=('any')
11 url='https://www.psycopg.org/psycopg3/'
12 license=('LGPL3')
13 depends=('python' 'python-psycopg')
14 makedepends=(
15   'git'
16   'python-build'
17   'python-installer'
18   'python-wheel'
19   'python-setuptools'
21 _commit='0b4763dfb00dbbbf6f0d81b1fc9a7ddf98c52345'
22 source=("$_pkgname::git+https://github.com/psycopg/psycopg.git#commit=$_commit")
23 b2sums=('SKIP')
25 pkgver() {
26   cd "$_pkgname"
28   git describe --tags | sed 's/^pool-//'
31 build(){
32   cd "$_pkgname/psycopg_pool"
34   python -m build --wheel --no-isolation
37 package(){
38   cd "$_pkgname/psycopg_pool"
40   python -m installer --destdir="$pkgdir" dist/*.whl