upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-pyaes / trunk / PKGBUILD
blob99dd86a2f3f349ba6f88f5ce8e3cc57aa62249b8
1 # Maintainer: Morten Linderud <foxboron@archlinux.org>
2 # Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
3 # Contributor: Andy Weidenbaum <archbaum@gmail.com>
5 pkgname=python-pyaes
6 _pipname=pyaes
7 pkgver=1.6.1
8 pkgrel=10
9 pkgdesc="Pure-Python Implementation of the AES block-cipher and common modes of operation"
10 arch=('any')
11 depends=('python')
12 makedepends=('python-setuptools')
13 url="https://github.com/ricmoo/pyaes"
14 license=('MIT')
15 source=(https://pypi.org/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz)
16 sha256sums=('02c1b1405c38d3c370b085fb952dd8bea3fadcee6411ad99f312cc129c536d8f')
18 build() {
19   cd "$_pipname-$pkgver"
20   python setup.py build
23 package_python-pyaes() {
24   cd $_pipname-$pkgver
25   python setup.py install --root="$pkgdir/" --optimize=1
26   install -D -m644 LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.txt