upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-pydrive2 / trunk / PKGBUILD
blob473c0cd87ab574f1e7ef6a679721d0f4c72fab37
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
3 pkgname=python-pydrive2
4 _pkgname="${pkgname#python-}"
5 pkgver=1.15.3
6 pkgrel=1
7 pkgdesc='Google Drive API Python wrapper library (maintained fork of PyDrive)'
8 arch=('any')
9 url='https://github.com/iterative/PyDrive2'
10 license=('Apache')
11 depends=(
12   'python'
13   'python-google-api-python-client'
14   'python-oauth2client'
15   'python-pyaml'
16   'python-pyopenssl'
18 makedepends=(
19   'git'
20   'python-build'
21   'python-installer'
22   'python-wheel'
23   'python-setuptools'
24   'python-setuptools-scm'
26 _commit='0c632bf290d91444d9db6e5cdde9dd40bfadff3d'
27 source=("$pkgname::git+$url#commit=$_commit")
28 b2sums=('SKIP')
30 pkgver() {
31   cd "$pkgname"
33   git describe --tags | sed 's/^v//'
36 build() {
37   cd "$pkgname"
39   python -m build --wheel --no-isolation
42 package() {
43   cd "$pkgname"
45   python -m installer --destdir="$pkgdir" dist/*.whl