upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-pynest2d / trunk / PKGBUILD
blob8c391544fcb801c19abe0b848c13500635686c7a
1 # Maintainer: Jelle van der Waa <jelle@archlinux.org>
3 pkgname=python-pynest2d
4 pkgver=4.12.0
5 pkgrel=1
6 pkgdesc="Python bindings for libnest2d"
7 arch=(x86_64)
8 url="https://github.com/Ultimaker/pynest2d"
9 license=("LGPL")
10 depends=(python polyclipping nlopt)
11 makedepends=(sip4 cmake boost libnest2d)
12 source=(${pkgname}-${pkgver}.tar.gz::https://github.com/Ultimaker/pynest2d/archive/${pkgver}.tar.gz)
13 sha512sums=('67451e3817aa308827683153c9f1fae670d95d393fad3b9b10831f7e255469df3be73fa2f90101c6dbf4034c06b51c4b3d9a4aa242f36325bb943003b0ce1842')
15 prepare() {
16   cd pynest2d-${pkgver}
18   mkdir build
21 build() {
22   cd pynest2d-${pkgver}/build
23   cmake .. -DCMAKE_INSTALL_PREFIX=/usr
26 package() {
27   cd pynest2d-${pkgver}/build
28   make DESTDIR="${pkgdir}" install