upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-pyswip / trunk / PKGBUILD
blob1774a2f1a6ddce34570982046a07276985cba09f
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
3 pkgname=python-pyswip
4 pkgver=0.2.10
5 pkgrel=3
6 pkgdesc='Python wrapper for SWI-Prolog'
7 arch=(any)
8 url='https://github.com/yuce/pyswip'
9 license=(MIT)
10 depends=(python swi-prolog)
11 makedepends=(git python-setuptools)
12 source=("git+$url#commit=9e9ca3e0059d156397fb020c2bdaef70f59529a6") # tag: v0.2.10
13 sha256sums=('SKIP')
15 build() {
16   cd pyswip
17   python setup.py build
20 check() {
21   cd pyswip
22   python setup.py check
25 package() {
26   cd pyswip
27   python setup.py install --prefix=/usr --root="$pkgdir"
28   install -d "$pkgdir/usr/share/doc/$pkgname"
29   cp -R examples "$pkgdir/usr/share/doc/$pkgname"
30   install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"