upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-pytest-runner / repos / community-any / PKGBUILD
blobd682bde836de7816c8f3f57ec6dfb3010eff45e3
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # https://github.com/pytest-dev/pytest-runner#deprecation-notice
4 pkgname=python-pytest-runner
5 pkgver=6.0.0
6 _commit=a3dc9f4c6afea684ed48da998958470ea41f3c00
7 pkgrel=5
8 pkgdesc="Invoke py.test as distutils command with dependency resolution"
9 arch=('any')
10 license=('MIT')
11 url="https://github.com/pytest-dev/pytest-runner"
12 depends=('python-pytest' 'python-setuptools')
13 makedepends=('git' 'python-build' 'python-installer' 'python-setuptools-scm' 'python-wheel')
14 #checkdepends=('python-pytest-virtualenv' 'python-pytest-enabler')
15 source=("git+https://github.com/pytest-dev/pytest-runner.git#commit=$_commit")
16 sha512sums=('SKIP')
18 build() {
19   cd pytest-runner
20   python -m build --wheel --no-isolation
23 # Tries to import barbazquux2
24 #check() {
25 #  cd pytest-runner
26 #  PYTHONPATH="$PWD" pytest
29 package() {
30   cd pytest-runner
31   python -m installer --destdir="$pkgdir" dist/*.whl
32   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/