upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-pywinrm / trunk / PKGBUILD
blob5963ce4f16e427db290030ffc0855f2457ba054c
1 # Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
2 # Contributor: Kevin Houdebert <kevin@qwazerty.eu>
3 # Contributor: Guillaume Brogi <gui-gui@netcourrier.com>
5 pkgname=python-pywinrm
6 pkgver=0.4.3
7 pkgrel=2
8 pkgdesc="Python library for Windows Remote Management"
9 arch=(any)
10 url="https://pypi.python.org/pypi/pywinrm"
11 license=('MIT')
12 depends=('python' 'python-requests' 'python-xmltodict' 'python-requests-ntlm')
13 optdepends=('python-requests-kerberos: for kerberos authentication'
14             'python-requests-credssp: for CredSSP authenication')
15 makedepends=('python-setuptools')
16 source=("https://files.pythonhosted.org/packages/source/p/pywinrm/pywinrm-${pkgver}.tar.gz")
17 sha512sums=('f6da28fc1c53a4c000539583ef5e6bdc108a2396f161a416cc151a8591478a6c7a577c5733374339fe3612a5a85046fb9cd44ca38f502aecd56b2723aae16943')
19 package() {
20     cd pywinrm-${pkgver}
21     python setup.py install --root="${pkgdir}"/ --optimize=1
24 # vim:set ts=4 sw=4 et: