1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
3 pkgname=python-qt-material
6 pkgdesc='Material inspired stylesheet for PySide & PyQt'
8 url='https://qt-material.readthedocs.io/'
9 license=('BSD' 'Apache')
10 depends=('python-jinja')
18 _commit='5a99be3d6914cd5570282b29968aa39a7f8d1408'
19 source=("$pkgname::git+https://github.com/UN-GCPDS/qt-material#commit=$_commit")
25 # first known commit to receive latest version
27 local _pkgcommit='5a99be3d6914cd5570282b29968aa39a7f8d1408'
29 git tag "$_pkgver" "$_pkgcommit"
31 #git describe --tags | sed -e 's/^v//' -e 's/-/.r/' -e 's/-/./g'
32 git describe --tags | sed 's/^v//'
38 python -m build --wheel --no-isolation
44 python -m installer --destdir="$pkgdir" dist/*.whl
47 install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE