upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-sphinx / repos / community-any / PKGBUILD
blob19f3f5db23bb396a0a7ce77e00354ef66e86d56c
1 # Maintainer: Johannes Löthberg <johannes@kyriasis.com>
2 # Maintainer: Daniel M. Capella <polyzen@archlinux.org>
3 # Contributor: SĂ©bastien Luttringer
4 # Contributor: Angel Velasquez <angvp@archlinux.org>
5 # Contributor: Fabio Volpe <volpefabio@gmail.com>
7 pkgname=python-sphinx
8 pkgver=7.0.1
9 pkgrel=1
10 pkgdesc='Python documentation generator'
11 arch=('any')
12 url=http://www.sphinx-doc.org/
13 license=('BSD')
14 depends=(
15   'python-babel'
16   'python-docutils'
17   'python-imagesize'
18   'python-jinja'
19   'python-packaging'
20   'python-pygments'
21   'python-requests'
22   'python-snowballstemmer'
23   'python-sphinx-alabaster-theme'
24   'python-sphinxcontrib-'{{apple,dev,html}help,jsmath,qthelp,serializinghtml}
26 makedepends=('python-build' 'python-flit-core' 'python-installer')
27 checkdepends=(
28   'cython'
29   'imagemagick' 'librsvg'
30   'python-filelock'
31   'python-html5lib'
32   'python-pytest'
33   'python-setuptools'
34   'texlive-fontsextra' 'texlive-latexextra'
36 optdepends=(
37   'imagemagick: for ext.imgconverter'
38   'texlive-latexextra: for generation of PDF documentation'
40 source=("https://pypi.org/packages/source/S/Sphinx/Sphinx-$pkgver.tar.gz"{,.asc})
41 sha256sums=('61e025f788c5977d9412587e733733a289e2b9fdc2fef8868ddfbfc4ccfe881d'
42             'SKIP')
43 b2sums=('f6193be4d63a1a6c04168b078a3da9e90da410b109b110b9b2402ce242321fae432c08318113b872c15eb5d822857b1cfc735c7f7ed65842cff12732cc31f232'
44         'SKIP')
45 validpgpkeys=(
46   '8A11B79A5D0D749A66F0A030102C2C17498D6B9E' # Takeshi KOMIYA <i.tkomiya@gmail.com>
47   'E9BEABB07E7B9CC3F56E62C91425F8CE5EBA0E07' # Takayuki Shimizukawa <shimizukawa@gmail.com>
48   'D3549119BD51B4AFE643E59752C8F72A61F0FB52' # Adam Turner <9087854+aa-turner@users.noreply.github.com>
51 build() {
52   cd Sphinx-$pkgver
53   python -m build --wheel --skip-dependency-check --no-isolation
56 check() {
57   cd Sphinx-$pkgver
58   LC_ALL="en_US.UTF-8" python -X dev -X warn_default_encoding -m pytest -v
61 package() {
62   cd Sphinx-$pkgver
63   python -m installer --destdir="$pkgdir" dist/*.whl
65   # Symlink license file
66   local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
67   install -d "$pkgdir"/usr/share/licenses/$pkgname
68   ln -s "$site_packages"/sphinx-$pkgver.dist-info/LICENSE \
69     "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
72 # vim:set ts=2 sw=2 et: