upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-sphinxcontrib-log-cabinet / trunk / PKGBUILD
blob95dc7332a70de286c7c73bce0a623c1579d6fbcf
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
3 _pyname=sphinxcontrib-log-cabinet
4 pkgname=python-${_pyname}
5 pkgver=1.0.1
6 pkgrel=4
7 pkgdesc='Organize changelog directives in Sphinx docs'
8 url='https://github.com/davidism/sphinxcontrib-log-cabinet'
9 arch=('any')
10 license=('BSD')
11 depends=('python' 'python-sphinx' 'python-setuptools')
12 source=("${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
13 sha512sums=('1f8c6a0b2c7432b42eb07246f5034b93724b90b6e2a5de3f77c3e72c6e928e150373b1abb553d601c4820fefe8b0dd72d1301fdd82366528c45ae3a158adb97d')
14 b2sums=('5df31c73590ebebd7c51cd0234e90f27d2034a0edd24cb4a3da875199e9357071b8adb63643c920cd185384e474fc0480b0943d4ac07b398d8ff4835571200a5')
16 build() {
17   cd ${_pyname}-${pkgver}
18   python setup.py build
21 package() {
22   cd ${_pyname}-${pkgver}
23   python setup.py install --root="${pkgdir}" -O1 --skip-build
24   install -Dm 644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
25   install -Dm 644 CHANGES.rst README.rst  -t "${pkgdir}/usr/share/doc/${pkgname}"
28 # vim: ts=2 sw=2 et: