upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-sqlparse / trunk / PKGBUILD
blobe2ee2871f89f91c978df6c74fcebbf4fa619b5e5
1 # Maintainer: Morten Linderud <foxboron@archlinux.org>
2 # Contributor: Jonathan Kotta <jpkotta AT gmail DOT com>
4 pkgname=python-sqlparse
5 pkgver=0.4.3
6 pkgrel=2
7 pkgdesc='Non-validating SQL parser for Python'
8 arch=('any')
9 url=https://github.com/andialbrecht/sqlparse
10 license=('BSD')
11 depends=('python')
12 makedepends=('python-setuptools')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/andialbrecht/sqlparse/archive/$pkgver.tar.gz")
14 sha256sums=('4f0562bbfe48242689cfe42c34ab035982b6c96a98c9753f458c00c6d147c20d')
16 build() {
17   cd sqlparse-$pkgver
18   python setup.py build
21 package() {
22   cd sqlparse-$pkgver
23   python setup.py install --prefix=/usr --root="$pkgdir" --skip-build
24   install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE