4 _name=${pkgname#python-}
7 pkgdesc='The Official API Spec Language for Dropbox API V2'
9 url='https://github.com/dropbox/stone'
11 depends=(python python-ply python-six)
23 source=($url/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
24 sha256sums=('dc5aff3fad1333188d4ddb4eee0a19d31e6262bb3cdf10c0bbdaeb309ff91a52')
27 sed -e 's|== 5\.2\.0|>= 5.2.0|' -i $_name-$pkgver/setup.py # Unpin pytest-runner version
29 # upstream doesn't seem to care about Python 3.11 compat: https://github.com/dropbox/stone/issues/288
30 sed -e 's/getargspec/getfullargspec/' -i $_name-$pkgver/$_name/frontend/ir_generator.py
35 python -m build --wheel --no-isolation
45 python -m installer --destdir="$pkgdir" dist/*.whl
47 install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"