1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
6 pkgdesc="Python implementation of subunit test streaming protocol"
9 url="https://launchpad.net/subunit"
10 depends=('python-extras' 'python-testtools')
11 makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
12 checkdepends=('python-fixtures' 'python-hypothesis' 'python-testscenarios')
13 source=("https://github.com/testing-cabal/subunit/archive/$pkgver/$pkgname-$pkgver.tar.gz")
14 sha512sums=('21413f0ed26f5f0572249ff4bcf948ea25d9185a1df73421836b9b21e11f323300f93a0275f0d64dc7c81a8e038fa0661a34f818bb038abf79c0637e051bc69e')
18 python -m build --wheel --no-isolation
23 PYTHONPATH="$PWD/build/lib" python -m testtools.run subunit.test_suite || echo "Tests failed"
28 python -m installer --destdir="$pkgdir" dist/*.whl