upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-threadpoolctl / trunk / PKGBUILD
blob3996f4629e3a1f4cd82e45a4715960c399588d57
1 # Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
2 # Contributor: Butui Hu <hot123tea123@gmail.com>
4 pkgname=python-threadpoolctl
5 pkgver=3.1.0
6 pkgrel=2
7 pkgdesc="Python helpers to limit the number of threads used in native libraries that handle their own internal threadpool"
8 arch=('any')
9 url="https://github.com/joblib/threadpoolctl"
10 license=('BSD')
11 depends=('python')
12 makedepends=('python-build' 'python-installer' 'python-flit-core')
13 source=("https://files.pythonhosted.org/packages/source/t/threadpoolctl/threadpoolctl-${pkgver}.tar.gz")
14 sha256sums=('a335baacfaa4400ae1f0d8e3a58d6674d2f8828e3716bb2802c44955ad391380')
16 build() {
17   cd "$srcdir"/threadpoolctl-${pkgver}
18   python -m build --wheel --no-isolation
21 package() {
22   cd "$srcdir"/threadpoolctl-${pkgver}
23   python -m installer --destdir="$pkgdir" dist/*.whl
24   install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE