1 # Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
2 # Contributor: Butui Hu <hot123tea123@gmail.com>
4 pkgname=python-threadpoolctl
7 pkgdesc="Python helpers to limit the number of threads used in native libraries that handle their own internal threadpool"
9 url="https://github.com/joblib/threadpoolctl"
12 makedepends=('python-build' 'python-installer' 'python-flit-core')
13 source=("https://files.pythonhosted.org/packages/source/t/threadpoolctl/threadpoolctl-${pkgver}.tar.gz")
14 sha256sums=('a335baacfaa4400ae1f0d8e3a58d6674d2f8828e3716bb2802c44955ad391380')
17 cd "$srcdir"/threadpoolctl-${pkgver}
18 python -m build --wheel --no-isolation
22 cd "$srcdir"/threadpoolctl-${pkgver}
23 python -m installer --destdir="$pkgdir" dist/*.whl
24 install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE