1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-tldextract
5 _commit=a7ecf90c92c1f1c8f011637437224fc980610237
7 pkgdesc="Accurately separate the TLD from the registered domain and subdomains of a URL, using the Public Suffix List"
9 url="https://github.com/john-kurkowski/tldextract"
11 depends=('python-idna' 'python-requests' 'python-requests-file' 'python-filelock')
12 makedepends=('git' 'python-setuptools-scm')
13 checkdepends=('python-pytest' 'python-pytest-mock' 'python-pytest-pylint' 'python-responses'
15 source=("git+https://github.com/john-kurkowski/tldextract.git#commit=$_commit")
25 python -m pytest --ignore build
30 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
31 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/