upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-tldextract / repos / community-any / PKGBUILD
blob4155f0a8f5a6d1776b4a7428f86e64fd49174e86
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-tldextract
4 pkgver=3.4.1
5 _commit=a7ecf90c92c1f1c8f011637437224fc980610237
6 pkgrel=1
7 pkgdesc="Accurately separate the TLD from the registered domain and subdomains of a URL, using the Public Suffix List"
8 arch=('any')
9 url="https://github.com/john-kurkowski/tldextract"
10 license=('BSD')
11 depends=('python-idna' 'python-requests' 'python-requests-file' 'python-filelock')
12 makedepends=('git' 'python-setuptools-scm')
13 checkdepends=('python-pytest' 'python-pytest-mock' 'python-pytest-pylint' 'python-responses'
14               'python-isort')
15 source=("git+https://github.com/john-kurkowski/tldextract.git#commit=$_commit")
16 sha512sums=('SKIP')
18 build() {
19   cd tldextract
20   python setup.py build
23 check() {
24   cd tldextract
25   python -m pytest --ignore build
28 package() {
29   cd tldextract
30   python setup.py install --root="$pkgdir" --optimize=1 --skip-build
31   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
34 # vim:set sw=2 et: