upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-unicodedata2 / repos / community-x86_64 / PKGBUILD
blobe380143c25a9666058233473b2639968fe2b7dfa
1 # Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
2 # Maintainer: Caleb Maclennan <caleb@alerque.com>
3 # Contributor: Guillaume Horel <guillaume.horel@gmail.com
4 # Contributor: Philipp A. <flying-sheep@web.de>
6 pkgname=python-unicodedata2
7 _pyname=${pkgname#python-}
8 pkgver=15.0.0
9 pkgrel=2
10 pkgdesc="unicodedata backport/updates to Python 3"
11 arch=('x86_64')
12 url="https://github.com/fonttools/$_pyname"
13 license=('Apache')
14 depends=('python')
15 makedepends=('python-setuptools')
16 checkdepends=('python-pytest'
17               'python-pytest-xdist'
18               'python-pytest-randomly')
19 source=("$url/archive/$pkgver/$_pyname-$pkgver.tar.gz")
20 sha256sums=('3793953ec7321eb9a01e398cac230aed557b9c7706e6b569b34ae6c442b8a2aa')
22 build() {
23         cd "$_pyname-$pkgver"
24         python setup.py build
27 check() {
28         cd "$_pyname-$pkgver"
29         python setup.py test
32 package() {
33         cd "$_pyname-$pkgver"
34         python setup.py install --root="$pkgdir" --optimize=1 --skip-build