upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-uritemplate / trunk / PKGBUILD
blobba4d82778761434f9d44248eee9bbec6dd288e58
1 # Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
3 pkgname=python-uritemplate
4 pkgver=4.1.1
5 pkgrel=2
6 pkgdesc="a Python implementation of RFC6570"
7 arch=('any')
8 url="https://uritemplate.readthedocs.io/"
9 license=('Apache' 'BSD')
10 depends=('python')
11 makedepends=('python-setuptools')
12 source=("https://github.com/sigmavirus24/uritemplate/archive/${pkgver}.tar.gz")
13 sha256sums=('64cae94edd83bbb0c2c49b15f2cb8192c3f8492af6bc468211d1e8b8496f5791')
15 build() {
16   cd "$srcdir"/uritemplate-${pkgver}
17   python setup.py build
20 package() {
21   cd "$srcdir"/uritemplate-${pkgver}
23   python setup.py install --skip-build --root="$pkgdir" --optimize=1
24   install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
25   install -Dm644 LICENSE.APACHE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.APACHE
26   install -Dm644 LICENSE.BSD "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.BSD