upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-wcwidth / trunk / PKGBUILD
blobabaee66027db2b5c3b6537e9724a5db1c46a61e1
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Kyle Keen <keenerd@gmail.com>
3 # Contributor: wenLiangcan <boxeed at gmail dot com>
5 pkgname=python-wcwidth
6 pkgver=0.2.6
7 pkgrel=1
8 pkgdesc='Python library that measures the width of unicode strings rendered to a terminal'
9 arch=('any')
10 url='https://github.com/jquast/wcwidth'
11 license=('MIT')
12 depends=('python')
13 makedepends=(
14   'git'
15   'python-build'
16   'python-installer'
17   'python-setuptools'
18   'python-wheel'
20 checkdepends=('python-pytest')
21 #optdepends=('')
22 _commit='f0232e5adfbcd7473021a5672c61ed79fee667f0'
23 source=("$pkgname::git+$url#commit=$_commit")
24 b2sums=('SKIP')
26 pkgver() {
27   cd "$pkgname"
29   git describe --tags | sed 's/^v//'
32 build() {
33   cd "$pkgname"
35   python -m build --wheel --no-isolation
38 check() {
39   cd "$pkgname"
41   rm -v tox.ini
43   pytest -v
46 package() {
47   cd "$pkgname"
49   python -m installer --destdir="$pkgdir" dist/*.whl
51   # license
52   install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE