1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Kyle Keen <keenerd@gmail.com>
3 # Contributor: wenLiangcan <boxeed at gmail dot com>
8 pkgdesc='Python library that measures the width of unicode strings rendered to a terminal'
10 url='https://github.com/jquast/wcwidth'
20 checkdepends=('python-pytest')
22 _commit='f0232e5adfbcd7473021a5672c61ed79fee667f0'
23 source=("$pkgname::git+$url#commit=$_commit")
29 git describe --tags | sed 's/^v//'
35 python -m build --wheel --no-isolation
49 python -m installer --destdir="$pkgdir" dist/*.whl
52 install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE